"Bone" head move


#1

I recently moved to the West coast from the East and even though I thought I was careful during the packing of all my "gear" I managed to somehow lose the small container that had my SD cards and backups for both my OpenROV project and a couple other projects I was working on. This is particularly frustrating in reference to the ROV project as I had everything working fine and now need to start over software wise. I keep telling my self to quit looking and move on but that those tiny cards represent a lot of effort. Time to stop beating myself up and get back to work.

In any case, my BeagleBone is white and my cape is one of the early ones (the revision number is blacked out so I don't know which it is). With Linux I can burn an image (dd) to my new card (same brand and size as my old card) but the Beagle Bone will not fully boot. It seems to be in some sort of a loop with flashing lights galore but never boots to a usable system. ( I can ping it, however no ssh or web access). I have let it try for over 8 hours and there is no change. I tried the 2.5 beta software and the 2.4 stable with the same result. Fter writing the card I see that it has a couple partitions (boot with a fat16 fs and rootfs with an ext4 fs) that look to be populated correctly. I can look at the card with gparted and it looks fine however i get the following error when trying to check the boot partition: "file system doesn't have expected sizes for Windows to like it. Cluster size is 2k (1k expected); number of clusters is 32695 (65263 expected); size of FATs is 128 sectors (255 expected). " Not sure what, if anything, to make of this. I have seen this error before but can't recall needing to resolve it. Just for the sake of completeness I had gparted fix this partition but see no positive result from that action.

My BeagleBone seems physically ok as I can install both Angstrom and Wheezy on it fine.

I am not using a block size flag with my dd command as none of the instructions I have found seem to require it. Don't know if that is pertinent. I have also tried a couple different cards, all 8GB in size. I think my previous cards were 4GB but would not bet on it. Again not sure if it matters.

Any hints? Thanks in advance.

Wayne


#2

Hi Wayne

I can take an image of my card for the BBW and old cape and send it to you. The only change you may need to do is in the tilt config for the camera, I had changed them to get more movement.

send me an email: seawinds@nb.sympatico.ca

Regards

Dave


#3

Dave,

That is a generous offer that I will accept. I continue to have no luck getting the BeagleBone to boot from the 2.4 or 2.5 images. Is it possible my Beagle Bone is not compatible with those images somehow? I don't remember what version of the software I was using before.

Thanks again.

Wayne


#4

Hi Wayne

The Image I took was from a 32GB card I had in the BBW hope that works for you. I think you should be able to burn it to a 2GB or 4GB card that that was originally used. Let me look for a ftp site to upload the file to and I will then give you the link.

I used Win32Disk to copy and burn it to the SD card on a windows system.


#5
  • Hi Wayne do you happen to have an ftp server I can upload the file to (450MB)

#6

Hi Wayne your file is on a ftp site ready to download.

please send me an email so I can give you the login username and PW.

your can Browse to ftp:metx.ca


#7

David;

tech.roberts@gmail.com

Thanks a bunch.

Wayne


#8

Hey Wayne,

I don't know the BeagleBone intimately enough to really help with this, but I wanted to at least let you know that I read your post about the situation. I would have expected the 2.4 stable image burn to work, and it doesn't seem to me that the size of the SD card would matter, but you're right that the original cards were only 4GB. Maybe see if you can find a 4GB card to use and try that just in case? Sorry- I wish I could help more. Please let us know if you have any revelations about what's not working right (the info could be useful to other people in similar situations).

Best of luck!

Eric


#9

Eric;

This morning I was able to get the 2.4 stable image to work on an 8 GB card. Call it stubbornness but it was bugging me so I kept at it. What worked for me was to first "prepare" the card by using fdisk to write a new MSDOS partition then use dd to write the image to the card. I have no idea why this worked and it might be something specific to how my computer is setup. (Lenovo T61 with Mint 13) I have duplicated this procedure and it works fine with two brands and sizes of card (Kingston and Sandisk, 8 gb and 4 gb).
Many thanks to David Murphy for sending me his image to help me over this hurdle. Any community is only as good as its members and he sets the bar pretty high.
Wayne

#10

Wayne,

I’m glad to hear it eventually worked out and YES, David Murphy is one of best! I’m glad that we have all started to form such a great community around this project. Hooray for “doing it together”!

E