Blinking Front illumination Leds trouble connecting to HUD


#1

Hi we are trying to figure out what is wrong with the open ROV s/n 915 we were able to connect to the HUD (but still had troubles with the camera being black but it would work after a couple of reboots) but now for whatever reason the 2 illumination Leds are flashing at approx once per second and it sounds like one of the motors are making a small ticking noise also when the hud comes up it does not show any voltage anymore… We managed to update the Image to the latest 30.0.2 (the problem was happening before this update) and verify that the update installed but we are still having problems connecting. the problem happens as soon as we plug the usb cable in to boot up the rov the blue led is on and flashing and the 2 lights on the Ethernet are on green/amber. It seems to me as if there may be a short or something somewhere even though we have never actually tested it in the water yet.
any help would be great thanks.


#2

Nobody has any suggestions? i still cant figured out the problem.


#3

Look at Dive lights flashing, no other problems


#4

Thanks for the link but i do not have the hud working and there was problems before the update to 30.0.2 I tried the troubleshooting guide and i did get a ping to work but the ping does not work each time .I then tried to connect with putty and i could not get that to work but not sure if i was doing it right or not. I tried a new Ethernet cable to plug into the PC as well … in the beginning we could connect to the HUD each time but the camera would not work unless we restarted a couple of times and the HUD was a buggy version so we could not get to the settings page. I was not able to get the arduino firmware updated after updating the BBB since it eventually stopped being able to connect to the HUD. im not sure what else to do. It would be nice to be able to use this ROV before the bad weather shuts in I have not even had it in the water yet.


#5

If you are not seeing the cylon pattern on the blue LEDs on the beaglebone the first thing I would try is to re-flash the software on the beaglebone (or re-image the SD card if you are using that) as my best guess is that your problems are due to corruption.


#6

Hi thanks for the reply I did reimage and reflash I get the cylonic blue led when the bbb is not attached but when it is connected to the ardiuno there is no cylon leds. Do leave the sd card in or take it out. I tried both ways with no joy.


#7

Another thing you might try is to disconnect the IMU if you have it connected, there has been previous posts where incorrect wiring of the IMU has prevented the beaglebone from starting up. If that doesn’t work you will need to start digging a little deeper as it would tend to indicate the issue is with the controller board.


#8

I will try the IMU but i am not sure where that is i have 3 toggle switches with a red button i am not sure what they are either maybe one of them got accidentally switched the wrong way. In the beginning it was connecting to the HUD every time ,other than the camera not initializing sometimes and the controls not working until I rebooted the rov a couple of times. i assumed that was because of the older software ,of course the troubles started before we even updated the BBB so something must have happened while the rov was powered up .


#9

The toggle switches with the red button is the ESC control switch and is used for programming the ESCs (motor controllers) these being switched the wrong way may stop the motors working but shouldn’t have any effect on the beaglebone booting up unless your batteries are not charged (if you haven’t charged them very recently, do this before anything else as it may explain your problem).

The IMU can be seen here though you may not have one as they are an optional extra that can be purchased with the ROV.


#10

I do not think there is an IMU and I had fully charged the batteries but they are 18650 batteries (3.7v) but they worked in the beginning. I would just like to note that someone else who was trying the rov out used only 3 18650 batteries on the right battery tube but the rov was working with only 3 batteries as well.


#11

The main reason I mentioned charging the batteries (other than this is a good place to start with troubleshooting in gerenal) is that I have had the same issues (both the beaglebone failing to start or the camera failing to start) when working off a bench top power supply due to not being able to supply the surge current at startup, and that your problem seems to have gotten worse over time. It may be worth checking the individual battery voltages as its possible that this could happen as a result of dodgy cells.

Beyond that, from your description it sounds the controller board is booting up fine (the blinking lights are indicating that it is not receiveing anything from the cockpit, and I suspect the noise you are hearing is the camera servo trying to hold position. both normal). It also sounds like the beaglebone is getting power (you noted in your first post that the ethernet lights and blue leds are blinking) but failing to boot (no cylon pattern), and that the image on the beaglebone is fine. My suggestion would be to eliminate as much as possible from the equation, disconnect the camera, switch of all the ESCs and see how you go. If it still wont boot consider desoldering any connections other than the battery and tether connections on the D25 connector, if you still get nothing you are basically down to a hardware fault on the controller board.


#12

You might try covering the Tenda board to make sure it doesn’t short the beaglebone. This sounds similar to a connectivity problem we had that was solved by a piece of electrical tape.


#13

Hey sorry i took so long i have been busy and took a break from troubleshooting the ROV as well.
Adam i could try different batteries i would have to order them but the voltages of all the batteries seem good and I assume the Tenda board is the one between the BBB and the Arduino It already has tape on it and doesn’t seem to be shorting.
Do i Leave the SD card in the BBB with 30.0.2 ? and why do i get cylon blue leds with the bbb out of the rov by itself and not when connected to the rest of the ROV?


#14

We have only released a FLASH version for the 30.0.2 version. This means after it has uploaded the software to the BBB you will want to remove the microSD card.

The cylon blue leds will be in this pattern once the BBB is completely booted up. What are you seeing when it is connected to the rest of the ROV?