BETA 30.0.3 software pre-release

release-notice

#1

I’m releasing a pre-release of the 30.0.3 software release that we want to get out in the next few weeks. As always, the OpenROV software is a living ever evolving project that needs your help!

Download: (You will need 7zip to uncompress the image)

You will need to install the image on a spare microSD card that is 2GB or larger.

Things that we would love feedback on:

  • Does the cockpit run smoothly. In 30.0.2 we see issues where you still get a connection latency indicator and motors work, but the connection light turns red and telemetry data stops updating. We are hoping that moving to the latest Kernel fixes that issue.
  • Does the system reliably boot every time? No more re-imaging the SD card? We were early movers to the ext4 file system on Linux and it bit us in the butt. A big reason to moving to the latest Kernel was to get all of the fixes over the last 6 months to make the file system reliable.
  • Generally, are you seeing anything that has you question the stability of the software.
  • Does connecting to the ROV using a DHCP work reliably for you?
  • Does connecting to the ROV using http://openrov.local work reliably for you?

This pre-release covers an intensive month of updates to the software imaging process. As a results:

The download image size has been cut nearly in half (359.3 MB vs 656.6MB of 30.0.2) meaning faster downloads and more free space on the image.

/

The linux O/S has been upgraded to the latest stable linux Debian release code named ‘Jessie’. There are many improvements including a new system for managing services called systemd which brings the boot time to about 30 seconds.

/

The linux Kernel has also been updated to the 4.1.x series. This is a massive update and with it returns the ability for the BeagleBone black to manage its pins using the cape manager. This means this release SHOULD work on the original beaglebone whites. That’s right, this release should work with the original 2.3/2.4 ROV kits.

/

Cloud9 works again! This is one of the improvements that I really want to get out and in to everyone’s hands. Not only can you edit all of the code on the ROV via your web browser, you can also debug the running node.js processes, batch upload files to and from the ROV, and much much more. Cloud 9 runs on port :3131 of your ROV.

/

This image support mDNS. That means you can now connect to the ROV using http://openrov.local:8080 to get to cockpit. To use this from your host machines, you either need Windows 10, Linux, or OS/X, or you need a Windows box that has iTunes installed. If it does not work for you, you can still use IP address.

/

Internet access fixed. There was a problem with a file that was hosted on the Internet not longer being available that foiled the ROVs ability to tunnel through your browser to get out to the internet. That has been fixed which means you can download plugins again, and the Internet updates can work again.

/

No more setting your computer to a static IP address! This release has a DHCP server built in on the ROV. Just leave your ethernet connection to DHCP and the ROV will assign it a 192.168.254.x address. It takes my computer 10 seconds or so to get the address from the ROV. If this does not work for you you can always go back to the static IP address as it still works as well.

/

Improvements for IMU2. Should work on all boards and is smart enough to avoid additional magnetic interference for better heading hold

Known Errants

  • *testing fix:*samba is not working. ( https://github.com/OpenROV/openrov-software/issues/462 )
  • If you manually try and stop the proxy service because you have directly connected the ROV to a router or your computer via Internet sharing, the proxy fails to stop.
  • the external lights indicator shows full on when initially started. The external lights indicator sometimes does not appear ( https://github.com/OpenROV/openrov-software/issues/452 )
  • the image does not currently auto-expand to take up the free space on the SD card. If you want to expand, you must manually run the script `sudo /opt/scripts/tools/grow_partition.sh’ and then reboot.
  • flashing the beaglebone scripts are not yet working
  • IMU2 issues not yet resolved for 2.7 and earlier boards ( https://github.com/OpenROV/openrov-software/issues/455 )

Things we have not tested yet

  • Running on a beaglebone white
  • Flashing new ESCs
    * Over the Internet software updates

How install a plugin?
Blinking lights and freezing compass and depth meter
Constant resetting of ESCs
No current from one battery tube
Troubleshooting IMU2 orientation data freezing shortly after boot
Am I Missing Something in Assembly?
#2

Debugging using Cloud9

  1. From dashboard stop the cockpit service
  2. Open cloud9 http://openrov.local:3131
  3. Open the /cockpit/src/cockpit.js file
  4. Stick a break point on the some code you want to stop on
  5. Right click on the cockpit.js file and choose RUN
  6. Connect to the cockpit using your browser http://openrov.local:8080
  7. Cloud9 will stop execution wherever you have a break point and highlight that line. From there it is a full on IDE where you can mouse over variables to see their value in realtime, step through code, etc.

#3

Updated the main topic with latest 30.0.3 pre-release that has the updated IMU2 code fixes.


#4

Added the flash version. The beaglebone blue leds behave differently with this flash version, the have a fast cylon mode right after boot while flashing and then go all 4 leds on when complete flashing


#5

I loaded this on a 2.8. With the software changes to the IMU you now have to run the motors for a few seconds before the IMU values will start to read in.


#6

Latency is still an issue with my 2.7 hardware and this version of software. The values seem to jump around randomly. I find when controlling either the camera servo, or the external servo, I can trash the connection due to high latency. When the connection drops, sometimes the IMU resets its heading, loosing cal. In addition, I have no indication when the external light (Alt I) is on. The good news is this is the first time I’ve seen anything other than depth from the IMU2.


#7

Updated the release:

Fixes the lights defaults, external lights not always showing, auto expand file system

Upgraded to Kernel 4.1.18, which includes a fix for embedded device clock that may or may not be relevant to us.


#8

Updated the release:

Its now possible to use and test the internet based updates. Because this is pre-release, when on the software update screen (via dashboard), select Advanced and select ‘unstable’ from the drop down. Then choose the refresh button and it will give you an option to install an update. For this build (rov-suite#194) I have also pushed a #195 that you can try upgrading to.


#9

@k_deboer Thanks for the report. The more recent builds take care of the light issue. If you could include a screen recording of the cockpit as you cause the connection to drop, it would be very helpful.

Thanks again.


#10

hi,
i ve updated to 30.0.3 and i thought it would be good to have a topic for collect all issues.
so far, from a desk test (no dive yet with this version) this is what i ve noticed:

Battery indicator: no more 4 green | to say that battery is full even i ve added lipofe profile with min 8v max 12v. I ve noticed that this profile was already existing on 30.02 and gave me full 4 green indicator.
Leds keep blinking , pressing o or p don t change anything

Xbox controller works

in the upgrade tutorial it s written to remove micro sdcard after upgrade, if i do so, cockpit and rov are unreachable

Plugin installed worked, list is displayed

thxx for your great work!


#11

Hi there!!

Thank you for the update! Finally everything works! You made me a very happy man.
IMU works perfectly. Controls of the motors are good. Well, this is all from a desk-test. Will put it in the water soon.

Now, to answer your questions:

Does the cockpit run smoothly.

YES

Does the system reliably boot every time? No more re-imaging the SD card?

YES

Generally, are you seeing anything that has you question the stability of the software.

External lights turn on for no reason from time to time.
When I open Photos tab, I cannot return to the cockpit (tab doesn’t move back when I press the arrow). This doesn’t happen with Settings and Diagnostics tabs. And a connection with a ROV gets lost when I open Photos.

Does connecting to the ROV using a DHCP work reliably for you?

Haven’t tried yet

So, thank you for the update, these minor glitches I can live with, but IMU works, and controls are OK, which is the most important thing!

Thanks,

Ozi


#12

For me flash version working without sd.
When I did flash I wait until 4 LEDs from on go off. (Few minutes)
I am dealing also brust latency


#13

@ozren_hasan just want to confirm for our records. You have an OpenROV v2.7 with an IMU v2 correct?


#14

Updated the images. Fixes the issue where the lights flashing for no reason while driving.


#15

Ups, sorry! You are correct, I have OpenROV v2.7 with an IMU v2. All the problems with IMU were described in topic “Troubleshooting IMU2 orientation data freezing shortly after boot”

I would like to mention two more issues, but I don’t know weather they are connected to the ROV, cockpit, or laptop.
So, here it goes:

I use a Panasonic Toughbook CF 30 to control the ROV. It has a touchscreen. It’s very usefool as you have no need for mouse. BUT, buttons on the cockpit don’t work on the touch screen, only with a mouse. When I click on the screen, nothing happens :frowning:
The second issue is that numbers on the keyboard are useless. If I press any of the numbers, nothing happens… So, no power setting possible. May I suggest to add a possibility in the Diagnostics tab to change a keyboard layout?
Also (just a suggestion), is it possible to add to the diagnostics a possibility to change/reset tilt? To explain: it seems as I glued IMU with a small tilt (1-2 degrees), so I would like to correct it. Since I’m not familiar with linux or arduino, I don’t feel too confident to change the code myself.

Best regards, Ozi


#16

Hi Ozi. I’m planning on adding the IMU tilt/reset capability for our next release to help solve the exact problem you mentioned. Not sure when that release will be, but I’ll make a post when the feature is available and give instructions on how to manually add it until it becomes part of the package.


#17

Just updated builds. Fixed

  • issue with photo tab not closing
  • delay on IMU2 calibration

We are tracking a couple other items, but plan on going live at the beginning of next week.


#18

TESTED: http://bit.ly/rov-image-30_0_3-build76

DHCP seemed to work fine! Nice to be able to connect to openrov.local. Worked on my Windows 7 laptop.

I did a quick test running from the SD card and it seems stable. It was just a bench test. If I put it in the water, do I need to upload the firmware to the Arduino?

I notice that Alt-o and Alt-p do not adjust the external lights up/down. They are always on maximum. This was the case in the previous release I was running.

I could not access the “Network Share”, perhaps because I am running from the SD card? This works on the release I have flashed.

I went into Cloud9 and into the src/plugins/lights/public/js/lights.js file and there it says that Alt-i and Alt-o should work. But the code needs fixing.

There seems to be two issues. 1. I could not get the Alt-o and Alt-p bindings to work. I tried j and k instead. 2. The code does not seem to change the actual value. It seems to be missing the increment/decrement and a range check…

This code worked.

{
name: “lights.keyBoardMapping”,
description: “lights for keymapping.”,
defaults: { keyboard: ‘j’ },
down: function() {
self.intensity-=0.1;
if (self.intensity < 0) self.intensity=0;
self.setLights(self.intensity);
}
},
{
name: “lights.keyBoardMapping”,
description: “lights for keymapping.”,
defaults: { keyboard: ‘k’ },
down: function() {
self.intensity+=0.1;
if (self.intensity > 1) self.intensity=1;
self.setLights(self.intensity);

    }
  }

#19

Yep. Samba is the name for the file sharing service. Known issue at the moment:


#20

Loaded rov-image-30_0_3-FLASH-build62. What I initially thought was latency seems to be related to alt-z control. If I tap alt-z to move the external servo (linear actuator in the gripper on my unit), all is good, but if I hold the alt-z keys, the latency value shoots up, and crashes the link. It does recover now after a period of time. Making this version a lot more tolerant to this loss of comms. Main lights turn on with two bars in the display on their own sometimes.

I don’t use DHCP on this unit

IMU2 works great!

Great work guys. So excited to get it in the water over the next few weeks!