BeagleBone update failure


#1

Hi there,

I have the BeagleBone A6 and I've been able to put the OpenROV image on it (can ssh and view the cockpit), but I'm not able to complete the manual update. Looks like it's crapping out at the serialport install:

10442 error Failed at the serialport@1.1.1 install script.
10442 error This is most likely a problem with the serialport package,
10442 error not with npm itself.
10442 error Tell the author that this fails on your system:
10442 error node-gyp rebuild
10442 error You can get their info via:
10442 error npm owner ls serialport

So I found this issue: https://github.com/voodootikigod/node-serialport/issues/142

"This has been fixed in #138 and is waiting to be deployed.

For the moment you can either rollback to node version 0.8.x or by adding git://github.com/voodootikigod/node-serialport.git to your package.json in place of serialport's version number."

Long story short, I tried messing with the version numbers, but still had no luck. I've never used npm or node.js before so (hopefully) I'm doing something silly and there's an easy fix. I've tried this so many times, please help!