BeagleBone not working?


#1

Hello!

So I've managed to put my OpenROV together now and everything seems to work except I can't connect to the BeagleBone...

I've installed the lates image on the SD card but when i connect it to my router nothing is happening, the indicator lights on the ethernet connector isn't blinking or anything. It's not listed in my router and when I try to scan the network with angryIP it's not showing up either.

I checked the actual tether cable but there is no break in the cable.


#2

The cape seems to work, atleast a green LED is lit when i connect the power.


#3

use a patch cable from the BB to your router to make sure you can see it, before trying to use the medialink adapters and tether. If that works then you must make sure the patch cable that is used from the BB to the Medialink adapter is wired correctly or just use the same patch cable from the first test going from the BB to your router for now, because you would know that cable is ok.


#4

By patch cable you mean a regular ethernet cable (just like the one you have between you computer and the router)? If so then yes I've tried that. Still no lights indicating any connection, neither on the BB or on the router.


#5

Yes on the patch cable. If I recall you had this working at one point correct?

If you had it working then you must ask the ? what has changed. If you tried updating the software maybe there is an issue there, so you need to go back to basics.

It may also be a good idea to have the patch cable connected to the router before powering up the BB so that it get's an IP address from your router using DHCP.

Remove the cape and power up the BB using either the usb port or the +5V input connector, check the network ip's to see if it shows up then connect to the BB using Chrome or try using putty.if you have it's ip.

you can also try connecting the patch cable from the BB directly to your computer. By default the IP address of the BB is 192.168.254.1 sub net mask 255.255.255.000

set your computer's Lan interface to 192.168.254.2 sub net mask 255.255.255.000

you should now be able to connect to the BB using the 192.168.254.1:8080 with Chrome or Putty using 192.168.254.1

if you are unable to connect to the BB then you may need to reload the image on the BB.


#6

Hi Erik,

I also had this problem when I first connected my BB. Have you tried connecting it directly to your computer? I also tried a number of different cables (including crossover). I eventually found one that worked, I can have a look which when I get home. Also If you manage to get the lights coming up when you connect directly to the computer, you may need to enable internet sharing so the BB can use the same connection as the PC, in which case you would then need to change the IP address of the BB.


#7

Ok so I managed to get the BB working by connecting power through the usb and using a standard ethernet cable from the BB to the router.

So far so good, I havent tried to plug it back in to the cape and get power that way. I will try that later. However now I'm having a really difficult time trying to install the update to the BB.

I have tried to format the card and re-install the image. This seems to work fine, when I enter the IP to the BB i get a message in the browser saying "It works! This is the default web page for this server. The web server software is running but no content has been added, yet."

The problem occurs when I try to do the manual update from the instructions. I get a lot of "npm ERR" messages. So I've tried the solution from the instructions but using:

sudo bash
cd /opt/openrov
rm -rf node_modules
npm install

When it does this installation i get even more errors. So I've tried to do it again and again and again with the same results.

Any ideas on what I can do to solve it?


#8

Ok, that was wierd. I tried to re-do everything and after i formatted the SD card and installed the image again it started to work. When i tried to enter the IP adress to the BB i ended up in the cockpit.

Should I still try to update the BB now when it's working? I will now try to put everything together and see if I get power to the BB through the battery packs.


#9

Nope I get no power the the BB though the Cape... There is a green light on the cape though but no green light on the BB and the ethernet connector isn't lit either...

I tried to power the BB with the usb again while having it connected to the cape and the battery packs and then it fires up. However I the camera isn't booting up and i get no respons from any motor. It seems as the Cape isn't transferring anything to the BB.

Lots of questions in this thread but i'm pretty lost here at the moment. Trying to describe what's heppening the best i can :)


#10

OOOOkay... Some progress update again then I guess... I removed the jumper on the Cape where it says: Servo Power and guess what, now the cape supplies the BB with power and when I log in to the cockpit I get picture from the camera! Woho!

I still get no response from the motors, lights or servo though. Could this be because I haven't managed to update the BB?