Beaglebone Black Boot issue


#1

Is there a working BBB flash image for OPENROV yet? I have a HS team working on a ROV project that uses the OPENROV processing architecture except we want to use the cheaper BBB.


#2

I have made good progress, but still not working. I started with a working Ubuntu 13.04 running from eMMC and I have been working through the instructions here: https://github.com/OpenROV/openrov-software

The first snag is the node compile error documented in step 6. The next snag is the undocumented fact that the mjpg-streamer download from sourceforge is broken and you must download with "svn co https://mjpg-streamer.svn.sourceforge.net/svnroot/mjpg-streamer" to get it to compile.

There was another issue with mjpg-streamer looking for V4L not V4L2, but that was fixed with a symbolic link.

I have now made it all the way to step 13, but i get this error:

Error: Cannot find module '/home/rov/app'


#3

The latest image (from today): https://github.com/OpenROV/openrov-image boots on the BBB.

The issue is that the BBB doesn't boot right now when powered only through the cape.

Don't know why. Right now you have to power it first via USB and then connect the power to the cape.


#4

Thanks Dominik... I won't be able to give it a try for a few weeks due to vacation. When you get a chance could you highlight the changes that made the image work for both BB and BBB.


#5

Extreme NEWBY helping friend. Original BB white A6 pooched on the bench so replaced with BBB, loaded latest image noted above to BBB , powered up by usb , booted, cockpit opens, camera image displays - all OK.

Plugged CAPE into BBB, powered cape with 12 volts , BBB did not boot ,

Powered BBB by usb with Cape attached to BBB but no power connected to cape nothing - no power no lights on either board

Question is how do you power BBB to boot up and then power Cape ?

Thank you in advance


#6

Bob,

The way I got it working:

1: Power BBB through USB with Cape attached

2: wait till it boots

3: power cape with 12v

(4 Optional: unplug usb)


#7

No luck
1 USB power to BBB without cape , it boots
2 connected cape to BBB
3 USB power to BBB no power light on either BBB or Cape
4 5 volt dc to BBB no power light on either BBB or Cape
5 12 volt to Cape power lights on Cape, power light on BBB but did not boot

Is there away to test the Cape as it is clearly preventing the BBB from being powered by its USB?
Thank you your help
Bob


#8

UPDATE - Can now boot BBB with Cape installed

disconnected Homeplug power connection to Cape and BBB powered up and booted with Cape connected and then powered Cape and it powered up , got an image and controlled the lights.

Now need to troubleshoot Homeplug and wait for someone to solve the BBB boot issue with power from Cape.

At least I can get on with the ESC , motor, prop bench testing .

Bob


#9

update: got a chance to try this. I powered the BBB with 5v supply and it powers the cape. Also have the cape motor power plug in so the 5 v will also power the motors. I don't have any power connected to the cape 12v input. Observations:

The video works fine...surprised to see the grid overlay which I don't need. Not sure what the grid is designed to support ( perhaps an attitude sensor.?)

Tried to upload an Arduino program using the setup option...the zip file unpacked ok and it got through all the steps except it would not pass the reset/upload step. Error message said upload failed.

I tried to control the motors and lights anyway. The motors would not run (using 5v) but the light voltage varied when I moved the light intensity slide bar. Strange...since I know the OpenROV Arduino program didn't load. Apparently the CAPE default Arduino program allows the outside light pin voltage (closest to the corner of the CAPE) to vary proportionally. The inside light pin voltage changes between two discrete values when the slider is moved.

Waiting to use my Arduino UNO to flash the CAPE Arduino chip.

Question: When the BBB boots with a CAPE installed, does it also attempt a default Arduino load?