Beagle Bone Software Installation


#1

Hi,

so i received my Beaglebone :-).

And i tried to install the openrov software with this site:

https://github.com/OpenROV/openrov-software

1. Ubuntu runs without any Problems

but i am not able not install open cv :-( i musst say i not the best friend of linux.

I've tried several tutorials on the internet but without success

Maybe it will help others also describe the installation of opencv in more detail. Can someone help me?


#2

Have you tried following the step by step instructions published on the wiki?

http://wiki.openrov.com/index.php/Installing_The_Software


#3

No i used the old one :-) but it looks like the same

It runs until Step "6: Fix V8 to compile" line 2

root@omap:~# git clone https://github.com/gflarity/node_pi.git Cloning into node_pi... remote: Counting objects: 43, done. remote: Compressing objects: 100% (34/34), done. remote: Total 43 (delta 13), reused 39 (delta 9) Unpacking objects: 100% (43/43), done. root@omap:~# cd ~/.nvm/src/node-v0.8.2 -bash: cd: /root/.nvm/src/node-v0.8.2: No such file or directory root@omap:~#

on Step 8 it looks like a misspelling


#4

It is very diffucult to read with text and code in the same line. i tried some combinations :-)


#5

Now its possible to compile but it is an error there:

[ 20%] Building CXX object modules/imgproc/CMakeFiles/opencv_imgproc.dir/src/smooth.cpp.o
/root/opencv/modules/imgproc/src/smooth.cpp: In constructor âcv::BilateralFilter_8u_Invoker::BilateralFilter_8u_Invoker(cv::Mat&, const cv::Mat&, int, int, int*, float*, float*)â:
/root/opencv/modules/imgproc/src/smooth.cpp:1357:10: warning: âcv::BilateralFilter_8u_Invoker::destâ will be initialized after [-Wreorder]
/root/opencv/modules/imgproc/src/smooth.cpp:1356:16: warning: âconst cv::Mat* cv::BilateralFilter_8u_Invoker::tempâ [-Wreorder]
/root/opencv/modules/imgproc/src/smooth.cpp:1295:5: warning: when initialized here [-Wreorder]
[ 20%] Building CXX object modules/imgproc/CMakeFiles/opencv_imgproc.dir/src/phasecorr.cpp.o
[ 20%] Building CXX object modules/imgproc/CMakeFiles/opencv_imgproc.dir/src/hough.cpp.o
[ 20%] Building CXX object modules/imgproc/CMakeFiles/opencv_imgproc.dir/src/distransform.cpp.o
[ 20%] Building CXX object modules/imgproc/CMakeFiles/opencv_imgproc.dir/src/thresh.cpp.o
[ 20%] Building CXX object modules/imgproc/CMakeFiles/opencv_imgproc.dir/src/precomp.cpp.o
[ 20%] Building CXX object modules/imgproc/CMakeFiles/opencv_imgproc.dir/src/undistort.cpp.o
[ 21%] Building CXX object modules/imgproc/CMakeFiles/opencv_imgproc.dir/src/linefit.cpp.o
Linking CXX shared library ../../lib/libopencv_imgproc.so
[ 21%] Built target opencv_imgproc
Scanning dependencies of target opencv_highgui
[ 21%] Building CXX object modules/highgui/CMakeFiles/opencv_highgui.dir/src/cap.cpp.o
[ 21%] Building CXX object modules/highgui/CMakeFiles/opencv_highgui.dir/src/cap_images.cpp.o
[ 21%] Building CXX object modules/highgui/CMakeFiles/opencv_highgui.dir/src/cap_ffmpeg.cpp.o
In file included from /root/opencv/modules/highgui/src/cap_ffmpeg.cpp:45:0:
/root/opencv/modules/highgui/src/cap_ffmpeg_impl.hpp: In member function âbool CvCapture_FFMPEG::open(const char*)â:
/root/opencv/modules/highgui/src/cap_ffmpeg_impl.hpp:366:39: error: âavformat_find_stream_infoâ was not declared in this scope
In file included from /root/opencv/modules/highgui/src/cap_ffmpeg.cpp:45:0:
/root/opencv/modules/highgui/src/cap_ffmpeg_impl.hpp: In member function âbool InputMediaStream_FFMPEG::open(const char*, int*, int*, int*, int*)â:
/root/opencv/modules/highgui/src/cap_ffmpeg_impl.hpp:1943:48: error: âavformat_find_stream_infoâ was not declared in this scope
make[2]: *** [modules/highgui/CMakeFiles/opencv_highgui.dir/src/cap_ffmpeg.cpp.o] Error 1
make[1]: *** [modules/highgui/CMakeFiles/opencv_highgui.dir/all] Error 2
make: *** [all] Error 2
root@omap:~/opencv/release#


#6

I've been working on that page off and on. It's very much draft. Please feel free to edit it and drop in notes as you go along.

I tried compiling the node v0.8.5 last night and got it to compile. I know OpenROV was working on it last night too. I'm curious if they've gotten further than I have.


#7

well i can safely say i am stuck around the same location ... perhaps we need to take a more structured approach to attacking it? my beagle has been installing over and over again for the better part of 2 weeks now!