Beagle Bone does not power up consitently


#1

Hello, I’m currently trying to diagnose a problem with my OpenROV setup, We have the 2.6 model with some of our own modifications, running the 30.0 disk image and associated firmware. Righty now we are bypassing the homeport connection, we plug the Ethernet directly into the Beagle Bone, and we’ve wired a short across the J-12 pads to allow us to power the board. We’re currently trying to get the setup working with a fixed power supply (12V 4A). The problem is the beagle bone will only boot up about 1/3 to 1/5 of the time upon supplying power to the board, when the boot fails we don’t see any LED’s on the beagle at all, including the power indicator. When it does boot up everything seems to work fine, furthermore by powering the board through the 5v input to the beagle (without the 12V attached at all) we can get a consistent boot up. Has anyone seen this problem or have any ideas as to what may be causing it?


#2

Please excuse the typo in the title…


#3

Although I haven’t seen the exact problem you’re reporting here, I’ve had a number of power issues with the BBB units to be honest. Out of curiosity, have you tried to connect serial debugging cable to the on-board serial header? All my power issues seemed to revolve around the power controller, and my units wouldn’t boot at all. But if the thing boots at least some times, then the power controller should be good I would think. So I would connect a serial debugging cable and see what it’s showing on the times when the unit won’t boot. I think you need to see if there’s any sort of serial port indication when it doesn’t boot.

TB


#4

@tcbetka has a good first step. If you can see some sort of serial output from the Beaglebone, you know its getting power, just not completing the boot and it may reveal your problem. If you can’t get serial information, start checking voltage along the path to the Beaglebone.

I know it sounds like power should just be ‘there’, but put a scope probe, if you have one, on the input to the LM25011 (or somewhere in front of it) and take a look at what your power source looks like when you turn it on. Power supplies take a relatively long time to ramp up their voltage when you turn them on, so be aware of that.

If power into the LM25011 looks good, see if you can check the outputs of the LM25011. First, take look at the SW output (pin 9) and see if you have 5V there. You may need to catch it during power on. If you check it during steady-state it might look like a good, solid 5V, but the Beaglebone may not react well if the output acts funny during power up. Alternatively you could take a look at the Power Good signal of the LM25011 (pin 3). You can also get to that signal from the LM25011 side of R13.

If everything looks good at the LM25011. then I’d start looking at the Beaglebone.

If you do anything TB suggested or take a look at the voltage levels during power on, I’d be interested to know what you see.

Hope this helps,
Lenny


#5

Hey Guys, Thanks for your suggestion, I apologize for the late response, I’ve been kept busy upgrading other parts of out ROV.
I wasn’t getting any sort of serial response on non-bootups so I took a look at the voltage upon startup using a scope. It turns out there was a huge voltage drop when I introduced the load of the ROV. This sort of weird transience on the power supply must have been the problem, because when I try to power up using the actual battery’s I get a consistent boot every time.
I’m not an expert in electronics by any means, but I assume this means my power supply is not able to source enough current? I was under the impression that 4A would be plenty, I’ve tried multiple power supplies so I’m fairly certain it’s not just the case of a bad supply. On Monday I’ll hook the battery’s to a mutlimeter and see how much current draw I see when they provide power for a startup. It’s not super critical to me to have a consistent bootup from a fixed supply, but I am curious at this point.

Thanks again for your help. We’re doing some pretty cool stuff with our ROV, I’ll be sure to post pictures when it’s all said and done.


#6

You are correct, the transient you are seeing on the power supply rail at power on is due to the power supply not being able to provide the inrush current of the ROV on powerup, which results in a brown-out on the BBB, apparently locking it up. The inrush is primarily due to the ESCs, one option is to switch off the ESCs before powering up the ROV, you can then switch them back on one at a time once the ROV has started up. This should prevent the problems you have been seeing.


#7

I probably should have been more detailed in what I’ve tried. All the behavior I’ve described has been with the ESC’s turned off. There may be some damage done to them (or some other part of the board) I once powered the board on a metal surface, shorting the whole thing for several seconds. This (I think) fried my home port adapter, but the ESC’s still appear to work (motors still work) but that could be an illusion or some other component could have been damaged.


#8

Hi Sean,

Adam is probably right about the inrush browning you out, but 4A should be enough. When I do development I run with a DC power supply connected at my battery tubes, works great and shouldn’t behave different than your setup. Do you have a current limit set on your power supply? That could cause the voltage droop if you’re limited at something like 1A.

Regards,
Lenny


#9

Hi All:

I’m coming late into this thread since I was out of the country for the last month.

Powering the ROV off a benchtop supply can indeed be problematic, due to the inrush current required by the ESCs. Turning the ESCs off won’t necessarily help this, since there’s still a big capacitor hanging off the power wires of the ESC, ready to pull down the bus voltage the instant you apply power to it. If the battery bus voltage gets pulled below ~6V, the 5V power supply cuts out, which stops the controller board’s Arduino, which then resets the ESCs, which starts the process all over again.

The 2.7 controller board attempts to ease this problem by slowing down the turn-on of the ESC power switch, MOSFET Q3. On a 2.6 controller board, the ESC turn-on happens very fast and requires a very large surge current- it would not surprise me that a 4A supply is not sufficient.

To get around this, if you’re powering the ROV off of a bench supply, you can hard-wire the ESCs to be on by placing a shorting wire across J17 (ESC power switch). That way there’s no ESC inrush current after the 5V supply is brought up. Just remember to take off this shorting wire once you switch to batteries, since the ESCs will be drawing power even with the ROV off.

Let us know how things are progressing.

-W