Bad ROV-day, almost lost my ROV


#1

Hi folks
I was out on the lake today with ma sailboat and my Openrov. First of all, my Logitech f710 wireless-gamepad seemed not to work any longer since the last update. The f510 (cable) was working, but only the motors, not the lights and not the camera-servo (where my grabber is). so I decided to dive anyway and use the keyboard, even if I hate that. At the beginning of the dive I noticed that both heading and depht hold were toggled on the screeen, but did not work to keep the ROV as intended.
While inspecting some of the mooring chains at our sailing-club, my thether got tangled and I could not get it loose (normally I use my grabber for that purpose, but the tangle was so close to the ROV, that I was not able to turn the ROV and use the grabber. After trying 15 Min. I had to dive to free it (3.5 meters down). I was lucky that I still had a diving mask on my boat. I managed to free the thether, but cut my fingers on the little mussels on the chain.
back in my workshop I tried again. Still no response to the gamepad, so I decided to re-upload the software from the sd-card. That worked fine, so I tried the online-update. After that I could not connect to the ROV again…
I call it a day!
still hoping that someone comes up with a new thether that ist slightly bouyant with a smooth surface. I hate this one!
I also hope, that my gamepads will work again, just as they always did (was there another Chrome update, that makes it fail?)
Hoping for the next problem-free dive (just like the previous ones)
Hub


#2

What version of chrome are you on? This is the second report in as many days…


#3

Hi Brian
I am using windows 8.1 and the version of chrome is: 43.0.2357.81 m
Best regards
Hub

Von meinem iPad gesendet


#4

Hi Hub,

I was using my ROV this weekend with Chrome 43.0.2357.124 m. I use an XBox One controller, worked great.

Best Regards,
Lenny


#5

Hi
After re-installing the software on a card I was able to connect to my ROV again.
I updated my chrome to the same version as you Lenny, but still have the same effect: if I connect my gamepad, the icon in the cockpit shows up for a second or so and then disappears and the gamepad does not work. It must be a chrome-issue, because when I open the cockpit with internet explorer, the gamepad icon stays and the gampad works (unfortunately the ROV doesn’t run on IE).
Do you have a solution Brian?
Hub


#6

If I understand the f510 which is wired does still connect? It is just the wireless controller dropping out?

I don’t have the hardware to repo your setup handy. If you can grab the console logs from chrome, I might be able to see what is going on.


#7

I looked into the joystick issue yesterday and determined theres a bug in Chrome on Windows. I went to file an issue this morning and someone else filed the issue 3 hours ago? If this affects you please head over to the Chromium issue tracker and star this issue so it gets proper attention:
https://code.google.com/p/chromium/issues/detail?can=2&start=0&num=100&q=gamepad&colspec=ID%20Pri%20M%20Week%20ReleaseBlock%20Cr%20Status%20Owner%20Summary%20OS%20Modified&groupby=&sort=&id=500931


#8

Hi
Thats seems to explain what I am observing. If I test both the 510 and 710 direktly on the computer they work fine, but not with chrome. In the cockpit, only the cable-version shows the icon for a short moment, the wireless one does nothing at all. So, I can just wait and hope for a solution.
Thanks for your efforts!
Hub