Am I Missing Something in Assembly?


#1

So I am very new to tech-based projects. I came across OpenROV as I think it is a brilliant technology that could greatly benefit my research. With that said, I guess I am not as technologically savvy as I originally thought since I have nearly fully assembled my OpenROV 2.8 kit, and the ROV is not operational. Here are some details:

  1. I am using a Mac OSX system

  2. Upon powering on the ROV, I can get the camera to work perfectly (using GoogleChrome); however, I cannot get passed this stage of assembly.
    *for example, I cannot get the lasers or motors to work, the 4 LED lights blink at one second intervals after approximately 1 minute of the ROV being on, etc.

So, I am thinking I am making a very silly mistake and skipping a major step. Therefore, my question is must I install software using the microSD card that comes with the kit to make the ROV fully functional? I wasn’t sure if the robot was already programmed or if I must do this myself. Any advice or help would be beyond appreciated as I am heading out for a major field expedition next Friday and this device is vital to my success! Thank you in advance.


#2

Can you specify what you mean with [quote=“craigpoconnell, post:1, topic:3619”]
camera to work perfectly
[/quote]

if you are able to access the camera live stream either through the Cockpit or the direct IP-address of the stream, usually this a hint that you did a lot of things correctly during the built.

In general it is highly recommend to update the ROV manually to the latest software release. All information about this can be found here: BETA 30.0.3 software pre-release

It takes the ROV usually a minute or two to boot. After that the for me the blinking lights sometimes occur to indicate a connection issue. Updating the software would be the first step to tackle this issue! Good luck!


#3

Thanks for the reply. When I wrote “camera worked perfectly”, I just simply meant that the cockpit opened and I was able to focus the camera and view it on my screen. However, upon placing the microSD card in the beagle bone - now the cockpit doesn’t open anymore. Seems like this process is going downhill for me.

I’ve read other forum threads where people had similar issues with not even getting the feed from the camera to work - and all seem to have been steered towards the support desk so I will do the same. But if anybody has any tricks that may be associated with getting around a GoogleChrome error message “Google Chrome could not load the webpage because 192.168.254.1 took to long to respond. The website may be down, or you may be experiencing issues with your Internet connection”, it would be greatly appreciated


#4

Hey Craig,

It sounds to me like you may have not uploaded firmware to the Arduino. If you’re able to get back to where you left off (with cockpit opening), you can simply click on settings and select the upload firmware button. This should bring up a dialog window that walks you through it. If you’re not able to get cockpit going again, there are a few things that may be going on. If you run into trouble there, you can always email support@openrov.com and someone can work with you 1-on-1 to solve the problem. Good luck with the final 5%!

Eric


#5

Thank you Eric! I made a lot of progress tonight, but hit another wall when trying to upload the firmware to the Arduino. I will send en email out shortly. Thank you!


#6

I have attempted to upload the firmware on to the Arduino again, but continue to get the same error message (I will attach coded thread below). However, it states that the micro SD must not be in the ROV. Therefore, should it not be placed in the computer either? I just want to make sure I am not missing something stupid like that.

Here is the output and error message:

undefinedstaging: build dir is /tmp/tmp.ua5gJW4Ahh
staged src in to build folder

staging plugins
mv: cannot stat ‘/tmp/tmp.ua5gJW4Ahh/src/Device.cpp’: No such file or directory
sed: can’t read /tmp/tmp.ua5gJW4Ahh/src/Device.cpp.template: No such file or directory
rm: cannot remove ‘/tmp/tmp.ua5gJW4Ahh/src/Device.cpp.template’: No such file or directory
src/OpenROV.ino
Searching for Arduino lib version file (version.txt) … /usr/share/arduino/lib/version.txt
Detecting Arduino software version … 1.0.5 (1.0.5)
Scanning dependencies of src
Scanning dependencies of arduino
Scanning dependencies of EEPROM
Scanning dependencies of SPI
src/CAutopilot_STD.cpp
src/Device.cpp
src/LibMPU_Quaternion.cpp
src/LibMPU_Vector3.cpp
src/CMS5803_XXBA.cpp
src/CPin.cpp
src/CCalibrationLaser.cpp
src/LibMPU_DMPDriver.cpp
src/CServo.cpp
src/CThrusters_2X1.cpp
src/LibMPU_DriverLayer.cpp
src/CCameraMount.cpp
src/CMotor.cpp
src/LibMPU_Calibration.cpp
src/CLights.cpp
src/CPIDController.cpp
src/NArduinoManager.cpp
src/NConfigManager.cpp
src/Utility.cpp
src/CTimer.cpp
src/CBNO055.cpp
src/CCape.cpp
src/NDataManager.cpp
src/CDeadManSwitch.cpp
src/LibMPU_I2CDevice.cpp
src/CModule.cpp
src/CControllerBoard.cpp
src/CControllerBoard.cpp:29:18: error: ‘A8’ was not declared in this scope
int temppin = A8;
^
.build/uno/Makefile:368: recipe for target ‘.build/uno/src/CControllerBoard.o’ failed
make: *** [.build/uno/src/CControllerBoard.o] Error 1
Searching for Board description file (boards.txt) … /usr/share/arduino/hardware/arduino/boards.txt
Searching for Arduino lib version file (version.txt) … /usr/share/arduino/lib/version.txt
Detecting Arduino software version … 1.0.5 (1.0.5)
Searching for Arduino core library … /usr/share/arduino/hardware/arduino/cores/arduino
Searching for Arduino variants directory … /usr/share/arduino/hardware/arduino/variants
Searching for Arduino standard libraries … /usr/share/arduino/libraries
Searching for make … /usr/share/arduino/hardware/tools/avr/bin/make
Searching for avr-gcc … /usr/share/arduino/hardware/tools/avr/bin/avr-gcc
Searching for avr-g++ … /usr/share/arduino/hardware/tools/avr/bin/avr-g++
Searching for avr-ar … /usr/share/arduino/hardware/tools/avr/bin/avr-ar
Searching for avr-objcopy … /usr/share/arduino/hardware/tools/avr/bin/avr-objcopy
Make failed with code 2
firmware-build.sh: : Compile of the Arduino image failed.
firmware-installfromsource.sh: Building Firmware Failed! Aborting

Thanks so much!


#7

Just in case any future members are having similar issues - I would like to say that the support team was beyond helpful in helping me assess the issues. After several days of continuous replies to my questions, the ROV is fully functional.


#8