All motors rotate but can still control speed a little


#1

Hey Everyone,

So I've updated the Cape and have the image on the BB. Also, the camera and lights work but servo doesn't tilt.

I programmed the ESC's and I thought I calibrated them correctly but for some reason when I turn the ESC on the motors start rotating (2 of them) and when I try pressing up or down the commands work but the motors still keep rotating in Idel.

Also, when I turn on the ESC's sometimes the camera freezes and I lose connection with the cock pit( I have a constant 12 V power supply so I'm not sure what happens)

Also the BeagleBone has a red ligt glow by the SPI IF and I'm not sure if that should be happining.

Does anyone have an idea what might be the problem?

Thank you very much in advance :))

-Pavel.A


#2

UPDATE:

Okay so now the motors don't rotate YAY!

Servo and Lights work.

The only thing is now that when ever I give any command..., up, down, left forward etc.. only the Starboard motor rotates...


#3

And the vertical one seems to kind of wobble but not rotate.


#4

Check to make sure you can run each motor from the Diagnostics window in the cockpit, if you can't then make sure you have all the esc switches turned on, maybe after programming them you left them turned off except the starboard one. When in the diagnostic window you can use the mouse and slider to move the motor but you can also use the right and left arrow on the keypad to move the slider, check to see if that works or not. If that works then you know the keyboard is working correctly. let us know how this checks out.


#5

Hello David, thank you very much for responding.

I tried running the motors from the Diagnostics Window and nothing. Also, for some reason even when I turn all the ESC off except for the vertical one, they all seem to glow and remain on, the Starboard motor still rotates.

I'll try to make sure I programmed them correctly and maybe I can re-calibrate them again too and see if that works


#6

Yes make sure you have them programmed correctly and Calibrated from the Diagnostics window. Also check to make sure you have the connectors plugged in correctly on the cape also remove the jumper on the cape. If you can't get the motors to move from the Diagnostics windows then I suspect the Arduino is not programmed correctly and worst case the BB may need to be reloaded but I suspect it's the Arduino.


#7

Hello,

Something wierd I found out just now. So when unplug from the CAPE all the ESC's the only one that beaps is my Starboard one which works, the vertical and port dont.

Also I ran through the Diagnistics only the startboard work and the other two start to glow but the motors don't even flinch. Also, I've just noticed that I calibrate the vertical one and when I turn it off and turn it back on the Calibration doesn't stay??? Like for the 1st green blink it should be set to 3 reds but when I turn it back on it goes back to 2 again.

Also, on the Cape there is this red light that blinks (picture attached) right next to the SPI IF

1247-mail.jpeg (10.2 KB)

#8

I've also re-uploaded all the software so that shouldn't be an issue.


#9

Never mind on the calibration. It seems to stay now.


#10

ok now that you have the Vertical Motor working from the Diagnostic Window, use that esc to test the other Port & Starboard connections on the Cape. just move the vertical Esc 3 pin connector over to the other ports on the cape one at a time, then test the port & Starboard sliders in the diagnostics window. If that works then your issue is with the esc's.


#11

Hello Daivd. Thanks so much for your help. THe robot is fully working now :) I did a bunch of troubleshooting and yeap the error was with the Cali. of the ESC's