About: openrov-image-master.zip kpartx


#1

hello,have anybody builded yourself *.img follow openrov-image-master.zip step by step?

I tried,but failed.here:
libmount.sh : function mount_image
after: kpartx -av ${media_loop}
there is only :
/dev/mapper/loop0p1
but /dev/mapper/loop0p2 not found

anybody could tell me why and how to solve ???

thank you so much.


#2

Dear Drian, could you give me some advice ? thank you so much.


#3

by the way,my pc is :vmware+debian8.3, I think all tools are installed.


#4

hello ,anybody ???

???


#5

We are working on a simpler way for people to build dev images.

@badevguru do you want to give the roadmap of this?


#6

Hi,Brian,That’s great work
We are full of expectations


#7

actually I found some other errors ,i don’t konw why:

02_update_image.sh:

chroot: failed to run command ‘/bin/sh’: Exec format error


#8

I have know why chroot fail ? but i havn’t solve the bellow problem,anybody could help ???

libmount.sh : function mount_image
after: kpartx -av ${media_loop}
there is only :
/dev/mapper/loop0p1
but /dev/mapper/loop0p2 not found

the image only have root partion,no boot partion,why ???


#9

Those are older build scripts that still used dual partitions on the inage. That has since changed.

We are using Robert C Nelsons omap-image-builder to build the BBB images. You can see the latest version with our updates here:https://github.com/BrianAdams/omap-image-builder/tree/openrov-dev-image?files=1


#10

Dear Brian:
Thank you so much ,i will try later…