2.8 cockpit connect timed out


A problem arose regarding the ROV which was working fine until yesterday: The ROV cannot be connected to the Cockpit.
According to Chrome, it was determined as an error of “connection timed out”. So, I downloaded another new SD image and uploaded it on my BBB.
However, although I tried this way, same error occurs.
Therefore, I also looked up the forum finding the related issues, but they could not solve my problem.
What is causing the “connection timed out” error?


There could be a number of things behind this. My go-to procedure in these cases is the following:

  • take out the BBB and try and connect it directly to the computer. You should be able to get the cockpit up. If no, then your BBB is corrupted and might need replacing. If yes, continue to next step

  • some times, I’ve seen the tendas become “unsynced” check the tenda manual to try and resync. If you have a spare topside interface you can test the tendas by connection one to the BBB and the second to your computer.

  • also check tether and other wires for continuity

  • we fixed a 2.8 with a similar issue a couple of months ago. We tested each component individually, and ended up having to change out the main controller board.

Good luck!