2.8 camera works, lights/motors do not respond, servo twitches


#1

Got the cockpit communicating over the tenda. I can view the camera livefeed.

i don’t think it is a power issue because the servo pops on and keeps trying to go upward

thinking about jumping j17 and j12 but that doesn’t explain the lights not responding does it?
i know the 2.6 had servos with switches, could it be that i need to toggle a switch (again that wouldn’t explain failure of lights)

in general, seems like i’m getting one way communication
i previously had this device working with this laptop, so i don’t think it is the laptop/browser, etc


#2

Update, I’m strongly suspecting a power routing issue to the ESCs.

I’ve tested using an older controller board with blown out Tenda (can’t get power to it, no green light on LED6), by connecting the topside ethernet directly to the BBB. I have total control of the rover–camera, lights, and all motors. Sadly, this controller is no good to me unless I can find a way to get power to the onboard Tenda.

When I instead use my newer controller board (which has a functional tenda, I can see the camera in cockpit), the lights on the physical ESCs do not turn on. I tried to repair this controller board by jumping J17–I get an ESC blink when I hook up the 25-pin but no lights from that point onward. Jumping J7 keeps the servo from twitching after cockpit launches, but doesn’t allow me to control it. Relatedly, I have no idea why I cannot control the lights.

I’d be happy if either controller board worked. I suspect an optocontroller is blown on each of them, so I think jumping is the answer. Ran out of things to jump though.


#3

Last update on this before I cave and buy a new controller board.

On the controller board with which I can see camera connected over Tenda, I cannot control motors or lights, ESCs do not light up (except a blink on startup): I also notice that the cockpit does not give me any details on voltage, action log, etc.
Does this additional fact–lack of logs in cockpit–help specify the breakage in my control board?

*Keep in mind that if I use my other controller board with broken tenda, but connect ethernet directly to BBB, I have full control of lights and motors, ESCs light green, and I can observe the log, I’d be happy to fix this board as well if I could shove power to the onboard Tenda somehow.


#4

Have you uploaded the correct firmware to the arduino on your controller board? It could be your arduino needs a firmware update given the motors, lights and servo aren’t working, which are all controlled by the arduino.


#5

To double check, I just installed 30.1.0~17.c84, the latest BBB image. No effect.

On my controller board with the functioning tenda, I can open the cockpit but cannot control anything or read the voltage/log, etc. The controller board is brand new so I would think the latest BBB firmware should be compatible. There must be a damaged component on the board but I can’t detect it.

I’m still surprised there is no place to steal 3V to power up my other controller board (the one which allows me to control everything when ethernet connected direct to BBB but won’t power the onboard tenda).


#6

@Jeremy based on your description of not getting any telemetry data it sounds like the BBB and the controller board are not talking. Make sure that the BBB is seated all of the way on the header pins on the controller board (white arrow in the picture).

Also the 30.1.0 branch of the software is still under development and is not a stable release. I would recommend using the latest stable release (30.0.3) in order to get your system up and running, and then if you want to switch to a dev branch you can do that later.


#7

When you connect to the cockpit on the BBB, have you pressed the button “Upload firmware to Arduino”??? When you update the BBB image you have to upload the firmware to the Arduino chip on the controller board as well, or the lights, motors / ESC’s and the servo will not function correctly. The Arduino on the controller board also handles reading battery voltage, connecting to the IMU and the telemetry data. I would recommend using 30.0.3 also.


#8

I installed
OpenROV-SUITE-30.0.3-jessie.204.531b22c-IMAGE-FLASH-30.1.0~17.c84fe0b

Connected to cockpit and successfully uploaded to the onboard Arduino. No change though, still no green lights on the ESCs.


#9

Well, I’m out of ideas… I would suggest opening a support ticket if you haven’t already. If your controller board is faulty, OpenROV support will probably send you instructions on how to fix it or a replacement part. https://openrov.zendesk.com/hc/en-us/requests/new


#10

I have a very similar issue with my cockpit. I’ve also tried all of the steps that have been mentioned above. In my case, the video feed comes through, the LEDs flash continuously and the motors, lasers and all other keyboard commands are unresponsive.

I have tried reflashing and updating the ardiuno. Am I looking at a faulty component at this point?


#11

Can you upload a screenshot of your cockpit screen?


#12

Mark, DId you make headway on this issue? I am have some similar behavior after an expedition.

t-